提供免费教程下载和网站搭建技术教程,主要分享和发布网站源码,致力创造一个高质量网络资源教程的分享平台

【易语言】【笔记】慢点学总会有进步的-第一天

发布:DXS2020-4-28 22:15分类: 技术教程 标签: 实用教程


.版本 2
.支持库 eAPI
.支持库 dp1
.支持库 shell
.支持库 spec

.程序集 窗口程序集_启动窗口

.子程序 __启动窗口_创建完毕
.局部变量 a, 整数型
.局部变量 b, 整数型
.局部变量 c, 字节集
.局部变量 d, 字节集
.局部变量 e, 整数型

取磁盘卷标 (“”)  ' 磁盘卷标,依旧默认运行文件的磁盘
取磁盘剩余空间 (“”)  ' 磁盘卷标空间,单位字节(1024*1024)
a = 取磁盘剩余空间 (“”) ÷ (1024 × 1024)
b = 1000  ' 盘剩余空间判定条件
.判断开始 (a > b)
    信息框 (到文本 (取磁盘卷标 (“A”)) + “空间剩余” + 到文本 (a) + “G”, 0, , )
.默认
    信息框 (“磁盘空间不足” + “空间剩余” + 到文本 (b) + “G”, 0, , )
    删除文件 (取运行目录 () + “\2020.ini”)
    删除文件 (取运行目录 () + “\2020.excel”)
    e = 0
    .循环判断首 ()
        e = e + 1
        打开指定网址 (“https://cn.bing.com/”)
        运行 (“iexplore.exe”, 假, 2)
    .循环判断尾 (e < 15)  ' 恶搞循环15次打开IE
    销毁 ()
.判断结束

.如果真 (文件是否存在 (取运行目录 () + “\2020.ini”) = 假)
    写配置项 (取运行目录 () + “\2020.ini”, “2020”, , )
    c = 解密数据 (到字节集 (读配置项 (取运行目录 () + “\2020.ini”, “账户记录”, “账户”, )), “1222542222545666dddd323”, 1)
    d = 解密数据 (到字节集 (读配置项 (取运行目录 () + “\2020.ini”, “密码记录”, “密码”, )), “1222542222545666dddd323”, 1)
    编辑框1.内容 = 到文本 (c)  ' 记住密码后二次登陆直接读取本地账户密码保存信息,正式发布前请删除末尾的文件删除信息
    编辑框2.内容 = 到文本 (d)
.如果真结束
.如果真 (文件是否存在 (取运行目录 () + “\2020.excel”) = 假)
    写配置项 (取运行目录 () + “\2020.excel”, “2020”, , )
.如果真结束
' 编辑框1.内容 = 读配置项 (取运行目录 () + “\2020.excel”, “账户记录”, “账户”, )
' 编辑框2.内容 = 读配置项 (取运行目录 () + “\2020.excel”, “密码记录”, “密码”, )  ' = =、、、,还不会写入excel


.子程序 取桌面路径, 文本型, 公开

返回 (取特定目录 (3))
取桌面路径 ()
信息框 (到文本 (取特定目录 (3)), 0, , )

.子程序 _选择框1_被单击, , , 账户密码保存按钮事件,写文件
.局部变量 a, 字节集
.局部变量 b, 字节集

.如果真 (选择框1.选中 = 真)
    a = 加密数据 (到字节集 (编辑框1.内容), “1222542222545666dddd323”, 1)
    b = 加密数据 (到字节集 (编辑框2.内容), “1222542222545666dddd323”, 1)
    写配置项 (取运行目录 () + “\2020.ini”, “账户记录”, “账户”, 到文本 (a))
    写配置项 (取运行目录 () + “\2020.ini”, #换行符 + “密码记录”, “密码”, 到文本 (b))
    写配置项 (取运行目录 () + “\2020.ini”, “运行文件位置”, “文件位置”, 到文本 (取运行目录 ()))
.如果真结束


.子程序 _编辑框3_内容被改变, , , 信息提示框



.子程序 _编辑框1_内容被改变, 整数型, , 需要增加限制只能输入数字与字母的混合输入法



.子程序 _编辑框2_内容被改变, 整数型, , 限制为只能有数字字母字符



.子程序 _按钮1_被单击, , , 按钮事件
.局部变量 a1, 整数型, , , 计次循环延迟数字,局部变量

a1 = 0
.如果真 (选择框1.选中 = 真)
    写配置项 (取运行目录 () + “\2020.ini”, “账户记录”, “账户”, 编辑框1.内容)
    写配置项 (取运行目录 () + “\2020.ini”, “密码记录”, “密码”, 编辑框2.内容)
.如果真结束
' 如果真 (选择框1.选中 = 假)
' 删除文件 (取运行目录 () + “\2020.ini”)
.计次循环首 (3, )
    .如果真 (a1 = 0)
        编辑框3.内容 = “loading”
        .计次循环首 (6, )
            编辑框3.内容 = 编辑框3.内容 + “.”
            延迟 (a1)
        .计次循环尾 ()
    .如果真结束
    编辑框3.内容 = “”
.计次循环尾 ()
延迟 (100)
按钮1.宽度 = 70
按钮1.高度 = 60
.如果真 (编辑框1.内容 = “”)
    编辑框3.内容 = “请输入账户”
    按钮1.宽度 = 56
    按钮1.高度 = 40
    a1 = 0
    返回 ()
.如果真结束
.如果真 (编辑框2.内容 = “”)
    编辑框3.内容 = “请输入密码”
    按钮1.宽度 = 56
    按钮1.高度 = 40
    a1 = 0
    返回 ()
.如果真结束
.如果 (编辑框1.内容 = “1” 且 编辑框2.内容 = “1”)
    信息框 (“登录成功”, 0, , )
.否则
    编辑框3.内容 = “账户或者密码错误”
    按钮1.宽度 = 56
    按钮1.高度 = 40
    a1 = 80
    打开指定网址 (“http://www.yhdm.tv/”)
    打开指定网址 (“https://cn.bing.com/”)
    运行 (“iexplore.exe/”, 假, 2)
    返回 ()
.如果结束
信息框 (“你竟然知道密码”, 1, , )
_启动窗口.可视 = 假
删除文件 (取运行目录 () + “\2020.ini”)
删除文件 (取运行目录 () + “\2020.excel”)
' 删除文件 (取运行目录 () + “\3.exe”)
信息框 (“由于你的操作,本程序即将销毁,保存的文件也会被删除”, 0, , )
' 删除文件 (取运行目录 () + “\*.exe”)
_启动窗口.销毁 ()


.子程序 _编辑框1_按下某键, 逻辑型, , 强制回车键转变登录1
.参数 键代码, 整数型
.参数 功能键状态, 整数型

.如果真 (键代码 = #回车键)
    _按钮1_被单击 ()
.如果真结束


.子程序 _编辑框2_按下某键, 逻辑型, , 强制回车键转变登录2
.参数 键代码, 整数型
.参数 功能键状态, 整数型

.如果真 (键代码 = #回车键)
    _按钮1_被单击 ()
.如果真结束


.子程序 __启动窗口_按下某键, 逻辑型, , 强制回车键转变登录3
.参数 键代码, 整数型
.参数 功能键状态, 整数型

.如果真 (键代码 = #回车键)
    _按钮1_被单击 ()
.如果真结束


.子程序 _编辑框1_获得焦点, , , 确保提示信息框内容一致为空

编辑框3.内容 = “”

.子程序 _编辑框2_获得焦点, , , 确保提示信息框内容一致为空

编辑框3.内容 = “”

  您阅读这篇文章共花了: 
温馨提示如有转载或引用以上内容之必要,敬请将本文链接作为出处标注,谢谢合作!

发表评论: